[BUG REPORT] Generic PC FydeOS Ver 14.2-SP1 - Chuwi Hi10 Go Intel Gen 11

Dear Team FydeOS,

First of all I would like to thank you for this wonderful Chromebook OS, it runs almost flawlessly on my Chuwi Hi10 Go running Intel Jasper Lake N5100 with Intel UHD 600, RAM 6 GB with Windows 11 build 2009 installed

I tested almost everything, and have been reinstalled 2 times, but there are some things that are not work as intended:

  • Chuwi Hi10 Go is a tablet PC, and supports touchscreen, and the touchscreen here are not working at all.

  • Chuwi Hi10 Go have Micro SD slot 2.0 built into the tablet, but it’s not detecting on FydeOS

  • When the device goes into sleep mode, it cannot wake or the screen just goes blank, I had to hard reset the tablet.

  • This tablet runs on Bluetooth 4.2 built in, but the bluetooth doesn’t work, it won’t budge in setting (cannot be turned on)

  • Gyroscope is not working, the tablet has gyroscope built in to determine portrait or landscape tablet orientation.

  • Sounds are not working - self explanatory

  • Widevine cannot be activated even when rebooting the device.

I think this is all I can find for now, if there are anything else to add, I will add them here, I hope this can be fixed for future release, thank you.

Note: The reason I’m using generic PC is because FydeOS for Chuwi which is for UBook 11.3 is stuck on Booting Local Image A from GNU menu, and this BIOS is not support legacy boot.

Edit: I did read about the faq https://fydeos.io/help/faq#fydeos-can-start-on-my-computer-but-a-device-cannot-be-recognized-what-should-i-do

I have tested my Chuwi hi10 go to boot on Ubuntu LTS 22.04 and tested if my problem on FydeOS is also existing on Ubuntu 22.04. Here’s what I found:

  • Touchscreen working properly

  • Micro SD slot 2.0 working properly, can write and read data inside SD Card

  • Bluetooth function as expected

  • Sound still not working, or perhaps because I only test them on bootable USB.

The bluetooth is working normally, but when I tried to activate widevine (which is not working after rebooting as instructed), after reboot, the bluetooth isn’t working.

we don’t have the exact same Chuwi model as yours, even if we do, it may not be the exact same as yours because certain components may vary for different batches. This is unfortunately not uncommon for brands and vendors like Chuwi, putting us in a very difficult situation in porting Linux.

It’s unfortunately a thing of ymmv, not much that we can do