Some things don't work

Hello, I am using an Acer Aspire Switch 10 E(SW3-016) device.
Processor model Atom X5-Z8300
Memory capacity 2 GB
Storage type eMMC 32GB
Intel HD Video Chipset.
Overall, FydeOS is going well, but there are a few issues I’d like you to fix.

  1. The built-in Wi-Fi does not work.
  2. Bluetooth not working
  3. No sound
  4. In games, the touchscreen does not work (not in all games)

me too i got that problem i have lenovo ideapad 110 , to fix it i had to reinstal every thing but with google sync it was faster and to avoid the chance of having this problem , i changed my chanel to developper mode ( note that it unstable but u got the latest update of fyde os ) after that i reboot and doesnt got the problem again , note also that it work on my laptop idk if it will work on yours but u can try it .

I have reinstalled many times but it doesn’t help. I will try this with developper mode.

P.С. I tried but it doesn’t work

Hey, how did you manage to install this OS on your tablet?
I tried to install it on my Xiaomi Mi Pad 2 (Intel-Atom-x5-Z8500) but it would not install. There was an error message I cannot recall right now.
Which version did you install?
Did you do anything else rather than flashing the OS on a pen drive and then boot from it (like it is described on the webpage)?
How is the overall performance? Sluggish?

Thanks in advance!