Material You theming refuses to work on FydeOS 17 @ amd64-fydeos

Detailed description

Clearly state your question(s)

  • Material You color scheme (#jelly-colors) did not seem to work on FydeOS Nostalgic Reflections. Although it did work with some of the elements on Chromium browser (Web Interface) and the revamped Quick Settings panel, nothing has changed on Files and Settings as if it was stuck on FydeOS 16.

The appearance menu also did not show any option related to changing the UI’s accent color whatsoever, only available options were just the account photo customization page, wallpaper customization page, and UI theme switch (Dark mode, Light mode, Automatic)

I tried Powerwashing, re-installing the OS but it is still the same. My first assumption of the issue was it remained there since I recently upgraded from FydeOS 16 to FydeOS 17.

Material You theming works with the “Try it first” feature via Live USB boot, but does not work when It gets installed on Disk which is very weird.

Feature(s) missing/not working:

  • Material you theming
  • Option to set accent colour
  • Similar UI on Files, Settings, Gallery, Diagnostics

“The colors were just bland, blank like a printer who refuses to print in color, or a highschooler who listens to Radiohead every single week.”

  1. Provide specific configuration and firmware version details:
CPU: Intel Celeron N3060 System-On-Chip 2 Cores @ 2.48GHz
GPU: Intel HD Graphics 400, Integrated
RAM & Storage: 
        RAM - 2GB SDDR3
        Storage - Seagate ST500LM030-1RK17D 500GB Hard Disk Drive
FydeOS Version: FydeOS v17.0 (FydeOS unlicensed version) Platform 15437.44.17.9 (64-bit)
FydeOS Image variant: amd64-fydeos
* FydeOS Installation is Dualboot, Legacy CPU *


Build Details: 

Chromium: Version 114.0.5735.121  (64-bit)
Platform: 15437.44.17.9 (Release Build v17.0) stable-channel amd64-fydeos-io
Channel: stable-channel
Firmware Version: 
ARC Enabled: false
ARC: 10061641
Enterprise Enrolled: false
Developer Mode: true

  1. Include detailed logs
    To obtain the logs, enter /var/log/messages in the Chromium browser and locate the relevant log fragment. Copy and paste it here.
LOGS TOO LONG!!! - Hosting logfile to Traff...
1 Like

i’m facing the same issue , i also tried everything with no success

Interesting to know that some people are also facing the same issue as mine, by any chance, did you install FydeOS using the amd64-fydeos image?

Photos and Media:

- I have exceeded the maximum amount of edits for this post, so I transferred them here for the sake of detail and conciseness. Material You not working on various applications, which is expected to work on FydeOS 17.

Options for Material You customization (Accent Color) are unavailable for my installation’s Personalisation settings.

Did you enable the flags according to the Release Note?

" * Added “Material You” support for customising accent colours of the system UI, matching your current wallpaper. Note that this feature is still experimental, so for some releases you need to turn it on manually by enabling all flags with the keyword “jelly” under chrome://flags"



i enabled all jelly flags still doesn’t work

I’m facing the same issue, and i enabled all jelly flags and it still doesn’t work

We found that turning on the jelly-related flags on some Intel Gen 3-8 devices may result in a black screen, so we disabled it. We’ll come up with a tutorial today for users to test the usability before enabling the feature.

Make sure you test it on a USB drive first.

1 Like

Greetings, Carrie!

I did what was prescribed on the Release Notes to enable Material You, however i was out of luck and it did not work.

I would be trying out the guide from the recent help article that you have provided. After that, I would be providing updates about this problem whether it fixed the bug or it remains the same.

Thank you so much!

Hello! I’m really glad to say that the fix worked flawlessly! Now everything looks as harmonized, more aesthetically pleasing to the eye, and now matches absolutely well with my setup!!

Thank you so much, FydeOS support!!:)