FydeOS Won't Boot/Install on Intel NUC7PJYH or Intel NUC7CJYH

  1. Clearly state your question(s)-

I Can’t Boot/Install FydeOS on My Intel NUC7PJYH or Intel NUC7CJYH Mini PCs. It Won’t Even Boot. No FydeOS Logo. Just the Image Selection Screen is Shown After Choosing the Installation Media from Boot Menu and Then Nothing Happens on Either of the NUC7s.

Yes I’m Choosing the Right Image as Per the Processor Generation.

I’ve Tried Booting with Both Secure Boot Enabled and Disabled.

I’ve Tried with Multiple Flash Drives as Well.

I’ve Tried Using Both Balena Etcher and Rufus for Flashing the FydeOS Image.

  1. Provide specific configuration and firmware version details-


CPU: Intel Pentium Silver J5005
GPU: Intel UHD Graphics 605
RAM & Storage: 2x8GB DDR4 2400MHz RAM + 500GB 2.5" SATA SSD
FydeOS Version: FydeOS 17


CPU: Intel Celeron J4025
GPU: Intel UHD Graphics 600
RAM & Storage: 2x4GB DDR4 2400MHz RAM + 120GB 2.5" SATA SSD
FydeOS Version: FydeOS 17

  1. Include detailed logs-
    Logs: Not Available.

Please Help Me.

Usually the troubleshooting is:
Go into into Bios
Disable GPU
Turn on AHCI
Disable secure boot
Turn on Virtualization options

Maybe start with defaults restart and then applie those changes…

Use an 3.0 USB Flash pen drive and use rpi imager to flash it.


I Followed Your Instructions But It Still Wouldn’t Boot. Nothing But Black Screen After Selecting the Install Media Flash Drive from the Boot Menu.

Also, There’s No Option to Disable the Intel UHD Graphics 605/600 in the Bios.

There’s No Discrete GPU in the System.

In the Chinese community, someone tried it on J5005 and it works. https://community.fydeos.com/t/topic/24119


I Tried with FydeOS 14.2-SP1 from the Thread You Mentioned in Your Comment.

Now I’m Stuck at Booting ‘FydeOS image A’. None of the Other Images Work.

well to disable gpu would only be the nvidia graphics card if you had one not your intel cpu

It’s too rare. Nobody can help you since no one has the same device.

Oh. After seeing ChromeOS Flex working flawlessly on them, I assumed FydeOS would be able to run perfectly on both of my Intel NUCs.