Couldn't find FydeOS account even though I made one

I created an account, but when trying to login to it with phone or email, it just says that it can’t find a FydeOS account. Same with the forgot password. If I press the sign up button, I get sent to a sign up page where a China phone number is the only option, which I don’t have.

However, if I press the + button and choose “other countries or regions” it takes me to a new sign in page, and putting in my login takes me to the account page but actually doesn’t sign me in.

What do I need to do here? Thanks

Use google account instead? try openfyde maybe?

Tried a XDA guide for google accounts and i still get the fydeos login when adding a new user

Did you download the image from Apparently, you are using the .com version.

1 Like

I downloaded the image from the pinned FydeOS historical releases

So you’re using the historical version? The historical versions are out of maintenance and may have problems that can’t be fixed now. Please use the new release.

It appears there was a server mismatch. You account was regestered at fydeos**.io**, their international server. However, when you tried to log in on fydeos**.com**, it wasn’t recognized as this is their +86 server. To resolve this issue, simply replace “.com” with “.io” in the URL bar, and you should be able to access your account as intended.