Surface Pro 4 - Unable to activate Android Subsystem

:pushpin:Question Description

Have you searched the community for related issues?

  • [ ] Yes, I’ve found some similar issues but no resolution

Please describe the problem you’ve encountered in detail:

  • Description:
    After installing FydeOS (the specific version for Surface Pro 4)
    and setting up a local user, the notification to activate android subsystem does appear. If i click it, nothing happens. If i try to install gapps, it says that it needs to be activated in android settings. When I search “Android Settings”, I only see “android preferences”. When I click on this, it brings me to the “Apps” section of the settings with absolutely no option or mention of the word “android”.
    This device should be compatible. Only using intel hardware. There were also previously documented versions by fideos for this device in which android subsystem was working.

:computer:System & Device Information

  • Hardware & System Configuration:
    • *Surface Pro 4
    • FydeOS Version: v17.0

Try to powerwash and reactivate the android subsystem.

Yeah, I’ve tried to wipe and reinstall around 4 or 5 times now and haven’t been able to get this working.
Oddly enough, sometimes when I reinstall the OS, the “activate android subsystem” notification doesn’t even appear, even after restarting a few times.
If it does appear at all, clicking it does nothing and just causes the notification to disappear. Would be nice if there was a setting button for this instead of having to rely on the notification working properly

I did misunderstand the difference between “wiping/reinstalling” and powerwashing. Regardless, I tried powerwashing, same behavior.

In fact, you don’t need to rely on notifications to activate the Android subsystem. You can click the Android App to do so, after activating the subsystem, it will turn to the settings menu.
Did you install it on the device’s hard disk or on another USB drive? We were unable to reproduce the issue you mentioned and have no feedback from other users with similar issues on Surface Pro 4.

You can refer to the video below, filmed on a Surface Pro 4, and the final step to the display settings item is a successful activation.

The app isn’t even there?

I’m having the same problem and yes, the app isn’t even there. Amarn, if you understand the message log maybe you could look at my posting regarding same issue with Surface Go2 to see if you can see what is going on.

It’s fixed now. You may try it again.