Surface go 2 [dualboot] booting to Windows disables rEFInd

I’ve installed FydeOS (dedicated version for Surface Go2 from your website), as second system on my M$ Surface Go 2. Everything went well as long, as I booted to FydeOS. Continuos reboots still brought me to rEFInd screen.

But after first boot from rEFInd to windows, I was unable to choose the OS on booting. Computer boots directly to Windows.

I have changed before installtion boot order so 1st is USB, 2nd Internal Storage, Last one Windows, but it doesn’t help.
I have also read FAQ and searched this forum before posting.

I have tried twice to reinstall fyde OS, and it was still the same: after installation there was rEFInd screen on reboot, until I choose WIndows, than rEFInd was gone and computer goes directly to windows.

I have red that in surface it’s common situation when you install linux as second system, and it should help to disable the windows boot manager via terminal. But since I am not a power user, I don’t know how to deal with it.

I need Windows as a second system.

Do you have any solution? FydeOS team?

Thanks in advance for any help.

This is an automatic operation performed by Windows. You may refer to this.

Enter shell in FydeOS.

Then enter:
sudo -i

Then you can adjust it according to the tutorial.

localhost ~ # efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,2001,0003,2002
Boot0001* rEFInd boot manager   HD(1,GPT,2cb8d418-6848-4222-9097-49ccc69c262d,0x800,0x82000)/File(\EFI\refind\refind_x64.efi)
Boot0003* Windows Boot Manager  HD(1,GPT,2cb8d418-6848-4222-9097-49ccc69c262d,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot2001* EFI USB Device        RC
Boot2002* EFI Network   RC
localhost ~ # sudo efibootmgr -Ab 3

efibootmgr: Boot entry 3 not found

Could not set active state for Boot0003: No such file or directory
localhost ~ #

it seems that there is en error making it impossible to inactivate boot entry, no matter which syntax of that command I use. ( sudo efibootmgr --inactive --bootnum 0003 returns the same info)

I have found others have similar problem on different linux distros. (steam os, arch linux)
One user reporteded that problem was gone when he downgraded efibootmgr to ver 17 (mine is 18), but I don’t know how to do it on fydeos.

can you provide me with more help?

Sorry, I haven’t encountered a similar problem. If you can find out how that user operates in other Linux, try performing the same operation in FydeOS.

Since sudo apt doesn’t work in FydeOs, what would be the syntax to uninstall efibootmgr? or which command should I use?

efibootmgr is a tool, so maybe boot any linux from usb, and try to use it instead of fydeos files? will it work? I’m on the trip and don’t want to brick my surface now, but I’m gona try and experiment when at home. I will let you know…

Are you using windows 10 or 11?

I’m using Windows 11.

Now as you mentioned it, it came to me, that before FydeOS, I have installed Chrome Flex with Brunch and Boot2Win as bootmanager, but removed both before FydeOS installation.
I wonder, if it matters.

Do you think I could try and do something from inside the Windows? If so, I would really appreciate some instructions, as I didn’t play with linux for years, and I don’t remember much.

I guess it’s a trick of windows 11. I am not familiar with windows. Did you search how to disable windows boot manager in windows 11?

Finally, I’ve found solution.

all credits goes to Roderick W. Smith,
Using bcdedit to Adjust Your Boot Priority

from powershell (administrator) you have to input:

bcdedit /set "{bootmgr}" path \EFI\refind\refind_x64.efi


bcdedit /set "{bootmgr}" description "rEFInd FydeOS"

et voila! after every restart, no matter Windows or FydeOS - rEFInd is loaded.

At this point, I’d like to thank the FydeOS support, for their NO commitment and help (however disappointing), as it forced me to do some work and learn something new.
And that is always a good thing.

I think you have the wrong idea about community. No one is obligated to help you, even fydeos support team, and people can only offer what they can. Carrie has told you they have not encountered your problem, so they can only offer the official advice of the surface-linux community. Communities exist because people help each other. If someone else helps you, show your appreciation. Even if others can’t help you, DON’T blame them.

I realize how the community works, and notice please, I do not blame anyone. What’s more, I thanked, although perhaps in an ironic way.
My disappointment came from the fact that I was using the trial period of a paid version of the system, tailored to my device, a version whose one advantage was supposed to be technical support. At the very beginning, I encountered a problem that I solved on my own for several days, which is not encouraging. And that’s about it.

P.S. I don’t know how to change topic, to ad [Solved]. I think it’s worth to flag it that way for others, should they encounter a similar problem.

Actually, the problem you experienced isn’t a fydeos problem, it’s more of a windows problem. And it’s not common. I am using surface go2 as well, but mine is working great. They are fydeos experts, not windows experts. Even if you’re a paying user, like me, you can’t expect the fydeos team to be able to fix all issues that are not internal to fydeos.