MS Surface Go 3 - no android subsystem

:pushpin:Question Description

Have you searched the community for related issues?

Please describe the problem you’ve encountered in detail:

  • Description:

The green android subsystem icon is not present on my tablet after several re-installations.
I cannot activate the subsystem in any way because it is simply not there.

Also it is impossible (after activating / installing linux) to turn on ADB debugging.

:computer:System & Device Information

  • Hardware & System Configuration:
    • Processor: Intel(R) Pentium(R) CPU GOLD 6500Y @ 1.10GHz
    • Graphics Card: Intel UHD Graphics 615
    • RAM: 8GB
    • FydeOS Version: 17.1 dedicated surface go version

i heard they fixed it a while ago, if ur still facing it,may be cuz of ur processor or sse4.2 instructions may not be available

There literally is a build and download for my tablet here;

also if they are saying they fixed it does that mean I need to download a new build or how exactly will the android icon reappear

So it seems I no longer have this issue as the android icon just appeared in my settings and I didn’t do anything in particular (apart from installing chrome extensions). This really makes me wonder if support did something here? And if so then how did it just appear on my surface without any acknowledgement from my side? Is there a Cron job that queries some central server and based on this displays or hides apps?

I would really like to hear from someone from support to explain this.

Downloading the Android settings app requires a connection to our server, which was offline for a while. Sorry for the inconvenience.

1 Like